How to continue using SupplierExpress
Starting January 2021, web browsers stop supporting Adobe Flash. To use SupplierExpress, install an Adobe Flash plugin version lower than 32.0.0.363 and a browser version which supports it.
Mozilla Firefox
To download and set up Mozilla Firefox, click Flash plugin and Mozilla Firefox
Internet Explorer
To set up Internet Explorer, click Flash plugin and Internet Explorer
Microsoft Edge
To download and set up Microsoft Edge, click Flash plugin and Microsoft Edge
Google Chrome
To download and set up Google Chrome, click Flash plugin and Google Chrome